Finally!

Forum for Subaru XT and/or XT6 owners

Moderators: Hocrest, Myxalplyx, Huck369, Moodybluesr, grossgary, john in KY, SUBBYRU89, austinXT6

Finally!

Postby Arghetlam on Fri Mar 25, 2016 5:28 pm

You may recall me, for the last couple years, looking to pick up an XT, or an XT6.

I finally got my hands on a '91 XT6! Hurrah!

It's not without it's hiccups, though. Trip computer doesn't work, cruise doesn't work, sounds like it needs a new rear axle, speedo cable isn't connected, and, sadly, the power steering pump is quite dead.

On the plus side. . .man, that thing can get down! I took it on a romp down my old road course, and it felt so planted, so stable, I could hardly believe it. Not to mention it sounds a bit like a Subaru possessed by a demon, and goes like it, too.

I imagine I'll be around for a while, picking up parts to get it back into good working order. Regardless, it's nice to finally be sitting on top of an Alcyone.
Arghetlam
 
Posts: 29
Joined: Sun Nov 02, 2008 4:37 am
Location: No Man's Land, Washington (Otherwise known as Spokane)

Re: Finally!

Postby john in KY on Fri Mar 25, 2016 6:19 pm

The power steering probably only needs the electric motor cleaned and new brushes installed. The cruise control won't work if something else has failed but I can't recall what that something else is.


Edit: The something else is the speedometer. The system needs a speed sensor signal to function.
john in KY
Moderator
 
Posts: 3164
Joined: Tue Jul 16, 2002 8:12 pm
Location: KY

Re: Finally!

Postby Caboobaroo on Sat Mar 26, 2016 12:43 pm

Like John said, the reed switch in the back of the speedo head gives signal to the cruise system and the power steering system since it's speed variable.
1989 Subaru XT6 - Black Mica
1989 Subaru RX - Black/Gold
2004 Subaru Legacy Outback Limited 3.0 sedan - White/Gold
User avatar
Caboobaroo
Veteran
 
Posts: 1402
Joined: Mon Jul 24, 2006 9:08 pm
Location: Oregon City, OR

Re: Finally!

Postby Arghetlam on Wed Mar 30, 2016 5:28 pm

Well, I got behind the dash. Looks like the speedo cable's plugged in, but for good measure, I pushed it in a bit just to make sure. Took it for a test drive, and verified that I had made the problem worse.

At speeds of over 25, the speedo will peg itself and keep bouncing. I'm a bit worried now that this could be a bit more of a serious problem. . .
Arghetlam
 
Posts: 29
Joined: Sun Nov 02, 2008 4:37 am
Location: No Man's Land, Washington (Otherwise known as Spokane)

Re: Finally!

Postby john in KY on Wed Mar 30, 2016 5:39 pm

Problem is either the cable or the speedometer head. I'd just swap both and be done with it. Replacing the entire instrument panel is no big deal.
john in KY
Moderator
 
Posts: 3164
Joined: Tue Jul 16, 2002 8:12 pm
Location: KY


Return to Subaru XT discussions

Who is online

Users browsing this forum: No registered users and 14 guests

cron